Export NZB function creates invalid XML

If you found a bug, please report it here.
Forum rules
When reporting a bug, please be as specific as possible.

To access the logfile in Finder:

If the programs crashed, please attach or email us the crash report AND logfile.

In Finder press SHIFT-CMD-G (or in menu Go->Go to Folder)
Then in the textfield enter "~/Library/Application Support/Usenetic" (including the tilde ~)
There you'll find the logfile called: Usenetic.log

Other issues:

You can always attach an image/screenshot with the problem for better understanding.
Post Reply
fronobulax
Posts: 2
Joined: Sat Nov 24, 2018 2:09 pm

Export NZB function creates invalid XML

Post by fronobulax » Sat Nov 24, 2018 2:20 pm

I believe there is a bug in the Usenetic Export NZB function.
As of version 1.2.2 Usenetic does not appear to be checking strings for required escape characters prior to writing the xml for the NZB file.

I'm not sure if you are escaping the other characters, but the "&" was not being replaced with "&" when it is part of the segment tag.

example
Usenetic 1.2.2 would output XML with the following error
<segment bytes="102394" number="1">12345678&abcdef@news.blah.blah</segment>
I believe it should put out
<segment bytes="102394" number="1">12345678&amp;abcdef@news.blah.blah</segment>

If I hand edit the "&" in your exported nzb files they pass XML tests.

User avatar
Support
Posts: 172
Joined: Tue Jun 06, 2017 12:38 pm

Re: Export NZB function creates invalid XML

Post by Support » Sat Nov 24, 2018 2:22 pm

Hi,

Thanks for the report.
This will be fixed as soon as possible.

Thanks!
If you like Usenetic, please give it 5 stars at MacUpdate: https://www.macupdate.com/app/mac/59624/usenetic

User avatar
Support
Posts: 172
Joined: Tue Jun 06, 2017 12:38 pm

Re: Export NZB function creates invalid XML

Post by Support » Sat Nov 24, 2018 2:34 pm

The issue has just been fixed in the source, but to make sure, do you have a file (MegaSearch result) that contains a segment with an ampersand?

Thanks.
If you like Usenetic, please give it 5 stars at MacUpdate: https://www.macupdate.com/app/mac/59624/usenetic

User avatar
Support
Posts: 172
Joined: Tue Jun 06, 2017 12:38 pm

Re: Export NZB function creates invalid XML

Post by Support » Sat Nov 24, 2018 3:24 pm

Ok, issue solved. All is working correctly now.

Thanks for the help, wikipedia and comment on MacUpdate :D

Update will be released this weekend.
If you like Usenetic, please give it 5 stars at MacUpdate: https://www.macupdate.com/app/mac/59624/usenetic

User avatar
Support
Posts: 172
Joined: Tue Jun 06, 2017 12:38 pm

Re: Export NZB function creates invalid XML

Post by Support » Sun Nov 25, 2018 8:18 am

Version 1.2.3 is released and has fixed the problem.

Thanks for your help.
If you like Usenetic, please give it 5 stars at MacUpdate: https://www.macupdate.com/app/mac/59624/usenetic

fronobulax
Posts: 2
Joined: Sat Nov 24, 2018 2:09 pm

Re: Export NZB function creates invalid XML

Post by fronobulax » Sun Nov 25, 2018 12:27 pm

Tested and verified. Thanks for the quick response!

Post Reply